Welcome to Our Community

Some features disabled for guests. Register Today.

C-Beam Machine XLarge

Discussion in 'CNC Mills/Routers' started by Moag, Jul 31, 2016.

  1. tetsuwan

    tetsuwan Well-Known
    Builder

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    5
    Hi guys,

    I'm just about to finish the mechanical bit of my XLarge and as I went along I noticed some things I would like to upgrade, like switching the two 20x60x500 to c-beams for 20mm more Z -height, and build a table from 20x80 v-slot instead of MDF.

    However, my main issue is the deflection on Z/X. This is me pressing on top of the spindle motor,

    I've been thinking about how to stiffen the X C-beam without changing the gantrys, but nothing really makes sense. I saw one build in the gallery that uses double c-beams joined together, but that means you have to extend the screws for the wheels (using threaded rods instead) and that creates new problems like mounting the Z-gantry.

    There is some space on the "inside" of the c-beam to add material, like L-shaped stainless steel or U-shaped aluminum. But the maximum material thickness is about 3mm to clear the acme blocks. Is that really going to make any difference?

    Any ideas out there?
     
  2. Giarc

    Giarc Master
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    511
    Likes Received:
    248
    Could you add 1/4 inch spacers and longer screws to the X axis axles then bolt on a 1/4 aluminum plate the whole length of the X on the side opposite the channel? I did something similar on the Y axis of my build.
     
  3. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    That's the whole idea of the build is to adapt it to your needs:thumbsup:, the hardest part is working out what they are and the real world limitations.;)

    What you're mainly seeing is combination of twist and deflexion of the long Xaxis C-Beam, which is hard get around. The best bang for your buck is simply reducing the span of C-Beam.
    Something that I'm planning to do on my build for that very reason, as its main use will be carving out curved 2.5D aluminium moulds where accuracy and rigidity is what is needed and not work piece size or speed. Still thinking about how I'm going to do it, but I think it is on the cards for my future.

    Have a look back to page 3 of this post to how I added a aluminium U channel to the C-Beam and this discussion of some alternative solutions. If you come up with some others, please share.. ;)
     
  4. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
     
  5. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    Echo:ROFL: Happy new year Glenn;)
     
  6. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    Has anyone tried adding a second set of vertical C-bea
    Happy New year to you too Craig... Dunno What happened there I was making a reply whilst having a Coffee waiting for my Wife shopping today... and she distracted me and I must have made a pocket posting without knowing LOL.

    Anyhow Here is what I was putting together to post earlier....

    Has anybody tried using an extra set of vertical supports either C-Beam or V-Slot in front of the X Axis Beam, I imagine this might help with the twisting as the X Axis then should no longer be able to twist at all but it will not help with the Flex due to the length, If anyone has a couple of extra 250mm Lengths of C-Beam it may be worth investigating.
    This was something that crossed my mind after the build and I will most likely try it but will have to order some extra Beam Lengths.

    On a another strengthening note.... I have not updated my log yet but over the Christmas break I pulled the Base Board off and fitted 20mm Aluminium Angle completely around the edge of the base board using screws every 50mm, This pulled the Base board into being very flat and no longer has a Visible sag between the two Y Gantry mounts, I suggest this should be something all XLarge builders do to there machines if using an MDF Base Plate as per the Build Manual.

    I was going to also route slots in the middle of the board to mount Angle inside there too but the strengthening on the outside edge has worked so well I really don't think it needs it now and the perimeter strengthening should be enough for most users, so I am going to stick with it as is.

    I will post some pictures tonight and provide a link.

    Cheers Glenn.
     
    Moag likes this.
  7. tetsuwan

    tetsuwan Well-Known
    Builder

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    5
    Not a bad idea. And there is actually 5mm longer screws in the shop. I'm a bit hesitant to offset the Z-axis from X even more than it is now, but it might be worth it :thumbsup:
    Maybe i can find a different spindle mount to compensate and get closer to X -axis again.

    Doh! Totally missed that ;)
    What are your conclusions of the u-channel? Was it worth all the sanding?

    I find the concrete/motorblock stuff very interesting. I was thinking of filling the cavities in the c-beam with steel flat bar and loctite metal filled polyester. Cheap, but might be tricky because it's so sticky and work time is only about 5min...

    I was thinking of something similar, but with 20x60 v-slot cut at an angle. One end at the top corner of the X C-beam and the other at lower front corner on the frame to make a triangle. Don't know if it helps or not, but at least I will have nice supports for splash guards ;)

    Thanks for all the input and for making an excellent forum :)
    Cheers!
     
    Glenn Weston and Moag like this.
  8. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    Here are the pics of the Base Board Strengthening that I did using Aluminium Angle.....

    [​IMG]


    [​IMG]
     
  9. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    Looks sweet Glen, you went all the way with the neat mitred corners...:thumbsup: I went down a slightly different path; I will upload some picks in a little bit, so you can have a sticky beak.
     
  10. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    _X8A4956.jpg _X8A4957.jpg

    Used some flat and angle stuff, cool T-Track from Timbercon (Auz) and polycarbonate. Still playing, as you do..;)
     
  11. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    That looks great @Moag, Perfect setup for the Cam Edge Clamps you have there.

    The MultiMaterial Blade that I purchased for the Compound Mitre Saw was money well spent, I have used it so much since fitting it for cutting all the little Aluminium Addon's and Mods.

    I certainly would not have been able to get such Nice Mitred Corners on the Aluminium Angle using a Hack Saw.
    Here is a Close up of the Corners.

    As you can see I filed off all the sharpies so as not to injure myself, can't seem to put that bloody file away....

    Glenn.

    20170106_130332.jpg
     
    Moag and GrayUK like this.
  12. jamesdjadams

    jamesdjadams Veteran
    Builder

    Joined:
    Nov 1, 2016
    Messages:
    39
    Likes Received:
    35
    Hi Everyone,

    I'm having an issue with one of my y-axis c-beam actuators. I've connected a TinyG controller board, the x-axis, z-axis and right-hand y-axis are working well. The other Y-axis actuator is another story. It seems to "jam" and the stepper makes a nasty noise. I removed the table-plate and the problem persists on the isolated actuator. Last evening, I disassembled / and reassembled it, re-adjusted the eccentrics, loosened the pre-load tension on the acme screw and reset the nylon thread blocks without any luck. If I jog it with the nylon thread blocks loose (wiggling) it "works" but after re-tightening them just enough to keep them from moving the problem returns. I tried adjusting the amperage up and down going to the motor and can't seem to get this fixed up. It will traverse back and forth a few times, then (usually near the same spot, 1/3 from the motor end), it seems to stall / jam. When I stop and then re-jog, it will move again fine.

    Any ideas / thoughts?

    -Jamie
     
  13. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    What happens if you swap motors between left and right ?

    Have you tried using a small battery powered cordless drill to drive the actuator, if there is any binding you will hear it straight away with the cordless drill motor being loaded down.
    Careful not to run to the end stops doing this though. Obviously you should run the cordless drill test with the actuator not connected to the table.

    I found a Philips bit in the end of the drill fitted nicely into the flexible coupling, you can even snug up the grub screw too.

    Glenn.
     
    jamesdjadams likes this.
  14. jamesdjadams

    jamesdjadams Veteran
    Builder

    Joined:
    Nov 1, 2016
    Messages:
    39
    Likes Received:
    35
    Hi Glenn,

    I will try your suggestions out tonight. If it does not move smoothly using a cordless drill what would the most likely causes of binding be? Eccentrics too tight? ACME screw pre-load too high / too low? One thing that I haven't tried is using a different connection for that motor (the TinyG supports four motors). I will try that also. I'm open to any suggestions!

    Thanks,
    -Jamie
     
  15. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    A good guide for eccentric adjustment firstly try to spin all the wheels one at a time with your thumb whilst on the beam, you should be able to roll them with some resistance, i.e. they should have some grip on the beam but should move with a bit of force while keeping the plate stationery with your other hand, all wheels should feel similar and try to make it so by adjusting the eccentrics. With lead screw removed and the plate on the beam, it should start rolling down the beam when tilted to 45 degrees, not before, on its own. I found that seemed be a good guide, if it doesnt move the eccentrics are too tight.

    I found another source of binding can be the nut blocks, loosen them off and re-feed the lead screw through them again and tighten but dont over tighten to cause deformation.

    If things are good you should even be able to push the plate along with the lead screw in place and screw will turn. I would also apply some dry lube to the leadscrews and that should also be a maintenance routine.

    Also for leadscrew preload try a little less than 1/4 turn for the screws on the endplates as suggested in the manual.

    The main thing to look for is any binding accross the full travel of the actuator.

    Hope that helps.

    Glenn
     
    jamesdjadams likes this.
  16. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    Just another thought, the leadscrew collar grub screws do not have much clearance, check for evidence of them possibly hitting the adjacent beam. File a flat spot on the leadscrew to rectify.

    Glenn
     
    jamesdjadams likes this.
  17. walkb4god

    walkb4god New
    Builder

    Joined:
    Oct 15, 2016
    Messages:
    4
    Likes Received:
    0
    Having issues with the motors. Does anyone have any suggestions? This was from an Xlarge kit.



    Motors are jerky. ​
     
  18. Giarc

    Giarc Master
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    511
    Likes Received:
    248
    Does it act jerky when the motors are running faster?
     
  19. walkb4god

    walkb4god New
    Builder

    Joined:
    Oct 15, 2016
    Messages:
    4
    Likes Received:
    0
    Yes, I tried to slow down and speed up the velocity and acceleration. It just jerks faster and slower. But the odd thing is that sometime, when I boot everything up, its smooth for a few seconds on all axiss' but then goes back to being jerky. I'll try to boot it up a few times while recording to see if I can capture the smooth steps before the high pitch sound starts and then its all jerky.


     
  20. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    If you are driving the Gecko 540 straight off the parallel port from the Laptop from MACH3 I think that will be the problem, I am running MACH3 using a Parallel Port on Desktop PC and experience the same issue but not quite as bad, I can get away with it.

    I have noticed if I do something like zoom in or out in the Tool path window or start another App in the background (Really Bad Idea) it's much worse, like what your video shows....
    I am Running Windows 7 and have not dropped back to XP, a lot of people suggest drop back to a very basic XP Install and disable as many drivers and devices as possible. The other Solution is a Smooth Stepper Board which bypasses the use of the PC Parallel port and is available in USB or Ethernet, and as suggested runs smoothly.
    Parallel ports are the old way now and you really had to have a fully dedicated machine to do the job properly, Many say Parallel ports on a Laptop is an extremely bad Idea due to power saving issues etc.

    You could try disabling ALL startup processes and drivers from MSConfig, Turn off WiFi and Disable the Network card, also get rid of any Antivirus software..... Turn off Windows Updates.... Everything you do not need running in the background.... You just want MACH3 Running that is all !!
    See if that improves things or at least settles it down to a usable state. I have been having too much fun cutting to drop back to XP to see if it improves but I will get to it eventually.

    Cheers Glenn.
     
    GrayUK and Moag like this.
  21. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    G’Day Jamie,

    Thanks for the information you’ve supplied, as the more detail the easier it is for others "like the ever helpful Glenn" to help. Good to see you have already started to go through the problem-solving process, to isolate the Jamming.

    On the first read, I suspect you acme lead screw is bent or damaged as you say it occurs near the same spot and the acme nut blocks wiggle when loose. So let us start there, Glenn has already given some good advice, so I will just add extra things to look at and do.

    With the problematic actuator isolated with the Stepper removed, leaving the flexible coupling attached to the acme.

    1- look to see if the C-Beam actuator is tight to the frame with no gapes, carefully clamp it down with a C clamp (loosen the screws first ), protecting the extrusions with a block of wood.

    2- Turn the acme by hand (use the Flex coupling) and feel for wobbles, grinding, bumps, tight spots and try to isolate their location. As Glen has noted the the lock collar can interfere with the frame (he’s got a fix on his build page or get a file and make a notch in the frame so it clears). The grub screw on the collar can also interfere if it is seated on top of a acme thread, filing a flat on the acme where its seated helps with this design fault of mine. If this is your problem remove the actuator from the frame. So you can have a closer "look see" for marks on the frame and inside the C-Beam.

    3- With the Actuator off the frame and flipped on its back so the acme is up. Turn the acme by hand again, looking straight down the acme screw looking for a bent acme ( because of damage or it being under too much pretension).
    If the acme is outside the actuator roll to on a flat surface, it should roll easily.

    If you have already filed a nice clean flat on the acme under the lock collar very slowly unscrew the grub screw to just relieve the pressure then slowly retighten, trying not to let the collar get out of square by pressing it back into the C-Beam End Plate with your fingers (don’t undo too much, just enough to relieve the pretension). The sense of touch can pick up any slight movements ("trust the fingers", assuming you’ve still got them all).

    Check for end play by trying to move the acme by pushing it inline with the axis back and forth. You will feel a little tap, tap if present. If you feel no taps, all's good.

    Now check for sideways play between the bearing and acme on both ends, trusting your fingers again. I found it to be a sloppy fit here so added some tape between the acme and bearing to reduce the rattling sound and get a tighter fit. Also make sure the bearing are fully pressed into the C-Beam endplates (a little lock tight will keep them snug, just don’t get it inside the bearings or they will seize).

    4- Move your gantry to the centre/er and loosen the nut blocks, so they are just able to move but snug. Now move it fully to either end and undo the four ends screws on the end plates just a little (snug). Get a soft piece of wood and tap the extrusion near the end plate so it finds its own centre/er to the lead screw, snug up the end plate again. tightening in a cross pattern. Repeat on the other end.

    5- Move the gantry close to one end and snug up the nut block closest to the end plate nice and square to the plate. This isn’t easy, use your fingers to hold it in place and feel that it hasn’t moved and tighten each side a little at a time and not to tight. Now move the gantry to the other end and repeat for the opposite nut block this time with a little pressure pushing towards the other one to remove any backlash keeping it square (it doesn’t need to be a lot, just enough so you can’t feel any play pushing the gantry back and forth).

    6- hand jog it though the full movement and feel for any binding, hard spots again or use Glenn’s method with the cordless drill. Feel down each V slot for damage and the acme for a damaged thread.

    Sorry for the generic scatter gun suggestions, but it might help others, fine turne their actuators.

    Let us know if you have any success or it's still jamming.

    Craig - aka Moag
     
    jamesdjadams likes this.
  22. Goran crno

    Goran crno Well-Known
    Builder

    Joined:
    Mar 12, 2016
    Messages:
    13
    Likes Received:
    5
    Hello
    I ordered the C-Beam Machine extra Large from Tronix Openbuilds....but I have a few problems....with the lock collar on the X-Axis.
    I Assembled the X-Axis C-Beam and Placed in place to the Side Frame.....but the lock collar of the X-Axis hit the Aluminium of the Side Frame.

    hope someone can help me please.....whats wrong here....strange...

    And by the way....I dont like the screws....the are like butter...not good material.. when I screw them in...the break...

    Thank you all for the Help

    Goran
     
  23. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    Yep design fault of mine @Goran crno... oops

    Have a look at clearcutter's build for a solution and Glenn's build for an alternative solution.
     
  24. Goran crno

    Goran crno Well-Known
    Builder

    Joined:
    Mar 12, 2016
    Messages:
    13
    Likes Received:
    5
    Thank you Moag
     
    Moag likes this.
  25. jamesdjadams

    jamesdjadams Veteran
    Builder

    Joined:
    Nov 1, 2016
    Messages:
    39
    Likes Received:
    35
    Thank you @Glenn Weston and @Moag for all of your ideas!

    My problem is resolved! I took the actuator off and tried the drill test followed by the lead-screw straightness tests. It looked straight and the drill showed no change in load. I had already filed small areas on the frame to compensate for the set-screws on the lock collars but re-measured to assure clearance. I took a break (...and maybe dropped an f-bomb) and re-read Moag's build instructions and found something I had missed about using Teflon tape between the acme screw and the bearings. Considering this and not knowing what my problem was, I decided to re-build the actuator from scratch. I'm prone to over-tightening things so this time I took a gentler approach. While assembling, I added Teflon tape where the acme screw met the bearings as well as the outside of the bearing itself to help compensate for the gap between it and the end-plate. I wasn't ready to commit to Loctite just yet and I was still unaware of the source of my problem. This really snugged up the gaps. I re-ran the drill test and straightness tests, all seemed well once again.

    After re-building the actuator, I took a break and fiddled with some TinyG settings. One setting that stood out to me was the travel per revolution value was set to 1.25mm. I adjusted it to 7.8mm (I now see that it ought to be set to 8mm - I'll do that tonight). I then re-assembled the works, wired it up for testing and BOOM (blood, fingers and smoke)... Just kidding, it was working very well! Because I have changed so many things I am not 100% sure of what the single or combined problems were. I'm glad that I did the Teflon tape work in any-case.

    This community is fantastic. I'm learning a lot and am very much enjoying it.

    I will be posting my build eventually (this seems like a good beer-drinking activity).

    -Jamie (aka. jamesdjadams)

     
    #265 jamesdjadams, Jan 12, 2017
    Last edited: Jan 12, 2017
    Moag, GrayUK and Glenn Weston like this.
  26. Glenn Weston

    Glenn Weston Master
    Builder

    Joined:
    Aug 1, 2016
    Messages:
    76
    Likes Received:
    102
    Great to see you got it sorted Jamie, you will enjoy every minute using this machine.
    Have a beer for me to while you do your write up, if there are few spelling mistakes we will know why.... LOL.

    Cheers Glenn.
     
    Moag and jamesdjadams like this.
  27. Moag

    Moag Master
    Staff Member Resident Builder Builder

    Joined:
    Mar 16, 2016
    Messages:
    183
    Likes Received:
    251
    :DWoo hoo, sweet build Jamie, just a little bit jealous of that slab of al, though.;)

    Looking forward to your formal build and thanks for posting the vid... it brought a smile to my face at least. Top job mate...:thumbsup:
     
    jamesdjadams and Glenn Weston like this.
  28. tetsuwan

    tetsuwan Well-Known
    Builder

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    5
    Nice plate for the table jamesdjadams! :)

    I finally got the time (and parts) to work on my first round of upgrades:)

    DSC01253.jpg
    Switched the 20x60 on the sides to C-beam. This gives me 20mm more Z-height and something sturdy to grab when I need to move the machine. You can also see the v-slot table =D

    DSC01251.jpg
    Used one of the leftover 20x60s as a cross member. Feels good since the machine will be moved around a bit. To assembly the v-slot table I used a 30x40x30x4 u-channel in the middle and 30x30x5 angles for the sides.

    DSC01252.jpg
    I could feel some deflection on the ends of the table. Luckily I was able to support the edge with a bearing :D. The aluminium will eventually wear a bit, but there is some room for adjustment when that happens.

    DSC01258.jpg
    I also got this 6mm aluminium plate for cheap, so I thought why not test it. Just needed longer bolts and extra spacers for the X-gantry. So was it worth it? I think so... Sure there is still deflection, but there is not much difference between the ends of travel and the centre, which means I moved the problem to next weak link - the wheels, bolts etc...

    Next up is wiring! But I don't know what cable to order. Ölflex Classic and IGUS Chainflex is quite expensive. Do you guys have shielded cables for your steppers?

    Cheers!
     
    Glenn Weston, GrayUK and jamesdjadams like this.
  29. PhotoSgt85

    PhotoSgt85 Veteran
    Builder

    Joined:
    Jul 27, 2015
    Messages:
    52
    Likes Received:
    52
    Im loving the upgrades in a large way tetsuwan! about to go make my bed out of Vslot as well
     
    tetsuwan and jamesdjadams like this.
  30. jamesdjadams

    jamesdjadams Veteran
    Builder

    Joined:
    Nov 1, 2016
    Messages:
    39
    Likes Received:
    35

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provides resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!